Zoom update required before May 30

/, News, Staff, Students/Zoom update required before May 30

Zoom update required before May 30

On May 30, Zoom is switching to a new encryption scheme. Any older Zoom clients (Zoom applications) prior to version 5.0 will not be able to connect after that happens.

For most users, Zoom may have already automatically updated your software. However, we recommend you verify that you are up to date. Run the “check for updates” menu item in your Zoom client.
Chromebook users should check the Chrome Web Store for any updates to the Zoom app add-on.
Information from Zoom about the change:
2020-05-22T08:58:16+00:00May 22nd, 2020|